Unfixed problems?

Discussion in 'General Modification' started by Ausir, Nov 11, 2003.

Remove all ads!
  1. darkwraith007

    darkwraith007 Member

    Joined:
    Nov 16, 2004
    Messages:
    6
    Likes Received:
    0
    Confirmed Bug

    Hi to all

    *short version*
    -If you initiate combat with hostile enemy while on a hill or other elevated surface, the game will CTD.

    *long version*
    Just to let you know, this is a CONFIRMED bug that I've done. This may explain many other "bugs" as well. In the developer diaries the devs state that their game engine doesn't handle elevation well, even though there are hills and stuff in Hommlet. This is why there are no aerial moves or enemies...cause of the engine :p

    Now then, if you encounter an enemy, but you are on a different elevation level then they are (on a hill by the church) and they spot you and go hostile (the goblin that hangs out by the church in Hommlet), then the game will do an instant CTD. It only happens once the enemy goes hostile, not before. This is because it has no way of calculating and compensating for elevation, so it just errors and crashes.

    *done*
    Lame, yes...but hope this helps at least a little.
    I'm willing to help beta-test and find bugs and stuff.
    Thanks.
    DarkWraith007
     
  2. Arkenor

    Arkenor Member

    Joined:
    Nov 22, 2004
    Messages:
    2
    Likes Received:
    0
    Using 3.0.4

    My Lawful Good gnomish Monk/Rogue, currently level 3 in both, does not get the option to level up in Monk upon reaching her next levelling. Was wondering if there was something amiss in the alignment requirements for level 4 monk or something. I can't find which file controls the PC levelling requirements to check.
     
  3. Huntsman

    Huntsman Member

    Joined:
    May 17, 2004
    Messages:
    48
    Likes Received:
    0
    When dual classing a Monk or Paladin, you cannot change and go back to that class. If you went from Monk to Rogue, you can't advance as a Monk again. This is per 3.5 Core Rules.
     
  4. Arkenor

    Arkenor Member

    Joined:
    Nov 22, 2004
    Messages:
    2
    Likes Received:
    0
    Doh, now I feel silly....
     
  5. veslach

    veslach Member

    Joined:
    Jan 5, 2005
    Messages:
    4
    Likes Received:
    0
    QuickSave not working

    I've been running the game with patches 1-3 installed & F9 & F12 (quick load & quick save) were working just fine. I then installed the latest Co8 patch that I could find - 3.0.4.2. I started up a new game & spent all night playing with F9 & F12 working like they did after patch3. I closed out of ToEE & left the computer running. Later, I had to shut down my computer because of a power outage (thank god for APC UPS). Unfortunately, now when I load any of the games I saved (including the 1st before I ever used F12) F9 & F12 don't work anymore.

    F9 - minimizes game & loads "My Computer"
    F12 - doesn't seem to do anything

    After checking the list of games i can load, the last quick save is still from last night when F12 was working.

    The only other mod I've done since installing patch 3 & then Co8's 3.0.4.2 is modifying the temple.dll file to allow for more than 5 PCs in the 2 locations mentioned by Shiftyjim in the thread "[SOLVED] having more than 5 PCs" at http://www.co8.org/forum/showthread.php?t=1031 & this was done prior to my playing ToEE last night (so stuff still worked after this mod).
     
  6. veslach

    veslach Member

    Joined:
    Jan 5, 2005
    Messages:
    4
    Likes Received:
    0
    Re: QuickSave not working

    This problem is NOT a problem.

    I'm not quite sure what happened, but something seems to have messed up badly. I tried to uninstall the game via 'Control Panel' & no luck, it was missing a file (C:\Progra~1\Common~1\Instal~1\Profes~1\RunTime\0701\Intel32\ctor.dll) so I checked the directory & there were only 1 or 2 files left there. I ended up copying the contents of 'engine32.cab' from the CD into that directory & it still couldn't uninstall. I ended up using the uninstaller that comes with ToEE & it did a beautiful job of removing everything including the item in 'Add/Remove Programs'.

    I rebooted (I wasn't taking chances). Reinstalled ToEE. I rebooted. I ran the game to confirm F9 & F12 worked. Installed patch1, patch2, patch3, & then ran the game to confirm again. I nstalled the No-CD game patch & ran game to confirm. Then installed the 'ToEE_Fan_Fixes_V3-0-4.zip' with a date of 2004-10-12 on it & ran the game to confirm.

    F9 & F12 work correctly now.

    Thank you for an awesome update & patch to this game.
     
  7. grac

    grac Member

    Joined:
    Dec 7, 2004
    Messages:
    4
    Likes Received:
    0
    :( cant go on with playing, cause of crystal mirror bug in temple lvl 2. have fought with the werewolfs and casted an AE Spell. So the mirror wanted to fight, too, but he does nothing and I cant kill it. Now I cant finish fights, b/c of this mirror (it is a known bug, hoped to get a fix here)
     
  8. zhuge

    zhuge Established Member Veteran

    Joined:
    Sep 27, 2003
    Messages:
    484
    Likes Received:
    0
    @grac:
    Get as far away as you can from the mirror. 2 or 3 screens width should be enough. If that doesn't work, press C. You should be able to get out of combat.
     
  9. grac

    grac Member

    Joined:
    Dec 7, 2004
    Messages:
    4
    Likes Received:
    0
    thx, it works :)
     
  10. veslach

    veslach Member

    Joined:
    Jan 5, 2005
    Messages:
    4
    Likes Received:
    0
    Spike(d) Chain Broken? & Bard/Sorcerer Bug

    is the use of the Spiked Chain broken?

    I've tried starting a character off with the 'Exotic Weapon Proficiency (Spike Chain)' & then went to see brother smythe in hommlet to buy a 'Spiked Chain'. It says my character is not proficient with this weapon. So I created a character with 'Exotic Weapon Proficiency (Spike Chain)' & 'Weapon Focus (Spike Chain)' - it still says I'm not proficient with this weapon.

    I'm not sure where to even start for debugging on this. Just guessing, but considering both Feats are for 'Spike Chain' (no 'd' on Spike) & the item is a 'Spiked Chain', that this is causing some sort of disconnect & it's not recognizing this as the same thing?


    I noticed the Bard/Sorcerer Bug while playing one. I'm using a buckler which has a 5% chance of spell failure so this bug doesn't happen as much as when I was wearing studded leather. I've only had this happen while using 'read magic' & 'identify' so not sure if it happens anywhere else & it appears to be an issue with the Radial Menu. As I don't want to waste my Sorc spells I tend to use the Bard's 'read magic' spell on scrolls & potions & this works normally until I get a spell failure due to armor. As soon as I get a spell failure things start going haywire.

    First, the spell is usually not removed from the # of 0th lvl spells I can cast (as shown on the radial menu). Not only that, but if I currently have 2/3 of my 0th lvl spells left it doesn't use up the remaining 2 spells before moving to 1st lvl spells. Sometimes it doesn't bother to remove spells from the 1st lvl either.

    Say I start with 3 0th lvl spells & 2 1st lvl spells. I cast 'read magic' & now I'm down to 2/3, 2/2. I cast 'read magic' again & get a spell failure, I'm still at 2/3, 2/2 (on the radial menu). Now I cast 'read magic' again with no spell failure & it shows I still have 2/3, 2/2 & there's no change on the sorcerer's spell list on the radial menu. I can cast the bard's 'read magic' another 3 or 4 times after that without anything changing on the Radial Menu & then it says I'm out of spell slots, even though the spell slots are showing as available on the Radial Menu.

    I thought this was just an issue with the Bard spells until I tried using 'identify' the other day. I had already gotten the spell failure & had run out of available spells for the Bard list & switched to using the Sorcerer's spell list. 'read magic' had a spell failure & the next 2 casts pulled off of the 1st level list (it's frustrating when the Radial Menu says I still have 0th lvl spells). Having 2 more 1st lvl spells left I cast 'identify' & had a spell failure. I cast 'read magic' again & instead of using the last 1st lvl spell it used a 2nd level spell. Still having 1 1st lvl spell left I tried 'identify' again & instead of it using the last 1st lvl spell, it also used up a 2nd lvl spell.


    Another thing I've noticed, but wasn't sure whether it was 'normal' or not... It does not seem like WIS amulets, INT headbands, or CHA cloaks increase the number of spells available to casters. I've not really played with this much, but I know for my cleric he didn't get any extra spells when putting the amulet on.

    I've also noticed that certain vendors now (with the Co8 update it seems) refresh their inventory. After leaving Hommlet for a while & returning several days later, Brother Smythe no longer has any of the equipment I sold him & has a new stack of the stuff I previously bought. This is nice, especially for archers as I've not been able to find any one else that sells arrows. It would be nice if several of the other vendors would do the same as well.

    thanks for the nice additions in the patch
     
  11. zhuge

    zhuge Established Member Veteran

    Joined:
    Sep 27, 2003
    Messages:
    484
    Likes Received:
    0
    Known bug caused by an earlier version of moebius's temple.dll
    Already fixed in the latest temple.dll. Get it here: http://www.jadri.com/temple.zip


    Hmm... the Bard/Sorcerer bug has been a known issue since ToEE's release. However there have recently been some new issues with spell slots as well. It may have compounded the problem or more likely unmasked it to a greater degree. I have already contacted moebius and am awaiting his reply on this.
    Also see: http://www.co8.org/forum/showthread.php?t=1241

    Known bug. See Atari buglist
    http://www.ataricommunity.com/forums/showthread.php?&threadid=388146


    Brother Smyth and Otis always refresh their inventory after a certain time has passed. It has always been so since the original release. Do not credit us for this.
     
  12. veslach

    veslach Member

    Joined:
    Jan 5, 2005
    Messages:
    4
    Likes Received:
    0
    Ack! I thought I had the latest copy when I installed everything last time. I'll go grab that & see if it helps.

    Darn, I was hoping this was part of the conversation scripts or something & that it could be duplicated for other vendors. Having Burne & the Herb shoppe in Nulb refreshing their inventories would be nice.

    Other vendors that I know for sure refresh their inventories include the priest in Hommlet & the Boatman's Tavern owner in Nulb. I may start another game & see if the other vendor in Nulb's Boatman's Tavern (who wants the real owner dead) refreshes his as well.
     
  13. Livonya

    Livonya Established Member

    Joined:
    Sep 25, 2003
    Messages:
    773
    Likes Received:
    0
    I know exactly what is causing this. It is an extremely easy fix. I will make sure it is fixed so it never happens again. Simple, simple, simple.

    Actually the same bug can happen with other items as well.

    Livonya
     
  14. Morpheus

    Morpheus Mindflayer Veteran

    Joined:
    Nov 11, 2003
    Messages:
    539
    Likes Received:
    0
    Have you fixed this yet, Livonya? I'd like to put this fix into the next mod pack, if possible.
     
  15. wonnilon

    wonnilon Member

    Joined:
    Apr 24, 2005
    Messages:
    2
    Likes Received:
    0
    wonnilon still levels up as an npc (not pc)

    I'm using the moebius and CO8 3.0.4 fixes, and the 'level up as pc' mod is not working for at least one npc (wonnilon). It does work for the other npc's I've tried: Zaxis, Fruella, Spugnoir, Morgan and Wicked.

    Not sure if this is relevant but hope it helps

    Wonnilon
     
Our Host!