Windows 8.1 mouse lag problem

Discussion in 'The Temple of Elemental Evil' started by florian1, Nov 28, 2014.

Remove all ads!
  1. florian1

    florian1 Established Member

    Joined:
    Mar 15, 2010
    Messages:
    460
    Likes Received:
    17
    I recently installed ToEE again, to try out v8.1.0 and KotB. After the usual problems installing on a windows system, I am left with only one, which is the mouse lag problem. I noticed it whenever I used an external monitor, but thought nothing of it as it was just to watch videos on the TV, and some lag in the mouse was pretty irrelevant. However, in a game, it is extremely annoying, and is happening with the built in monitor.

    Does anyone have suggestions on how to fix this for ToEE? It is the only game I own which has this problem.
     
  2. sirchet

    sirchet Force for Goodness Moderator Supporter

    Joined:
    Dec 6, 2003
    Messages:
    3,721
    Likes Received:
    49
    Try enabling and disabling scroll acceleration in the games options, (under the Preferences Tab) this cleared up mouse lag for me.
     
  3. florian1

    florian1 Established Member

    Joined:
    Mar 15, 2010
    Messages:
    460
    Likes Received:
    17
    Thanks for the suggestion. Unfortunately it did not make any difference. I notice it the most when creating characters and leveling up. It has been a while since I played, so perhaps it was always like this, and I have simply forgotten. I in fact wrote the post when I was still in character creation mode, and thought if this is what it would be like I would not bother playing. However, once under way, it does not seem a big problem.
     
  4. Gaear

    Gaear Bastard Maestro Administrator

    Joined:
    Apr 27, 2004
    Messages:
    11,023
    Likes Received:
    33
    Mouse lag has mostly been a thing of the past (for reasons I'm unclear on), so I suspect that incidences of it in modern times are more likely due to specific mice and/or drivers (or lack thereof).

    One thing you could try is to play in Windowed mode, which makes the Windows mouse active. (You can play quasi-fullscreen by selecting your monitor's native resolution and windowed mode together, which will make the window fill up the screen.) The only downside is you lose context mice - no wands when casting spells, bows when firing ranged, etc., just the Windows arrow.
     
  5. florian1

    florian1 Established Member

    Joined:
    Mar 15, 2010
    Messages:
    460
    Likes Received:
    17
    Mouse works perfectly in Windows mode. Thanks!

    The other downside of Windows mode is that I cannot move the view by holding the mouse near the screen edges. The arrow keys are more controlled, but a fella likes to be lazy.
     
  6. florian1

    florian1 Established Member

    Joined:
    Mar 15, 2010
    Messages:
    460
    Likes Received:
    17
    Additional bonus to Window mode is that I can now disable the opening video without the game freeing or crashing.
     
Our Host!