ToEE w/ Co8 on Mac OS

Discussion in 'The Temple of Elemental Evil' started by roolark, Dec 14, 2011.

Remove all ads!
Tags:
  1. roolark

    roolark Member

    Joined:
    Dec 14, 2011
    Messages:
    7
    Likes Received:
    0
    So, I managed to get ToEE w/ Co8 running almost perfectly on my intel i5 mac mini. The graphics are fantastic, the gameplay is smooth, all of the Co8 features seem to be working just fine, and I've finished the moathouse and still no corrupted saves :-D I used some of the information from the thread in this forum about using TFE-X-linux (although I was NOT able to actually get TFE-X-linux to run.

    DISCLAIMER:
    Really, you need knowledge of the linux command line for this to work, and you need some fearless qualities to overcome the myriad nasty error monsters along the way. It might be possible to actually create a script that would do most of this for the faint of heart, but I'm not that good.

    Here were my steps:

    PREREQUISITE:

    You MUST install apples XCODE developer tools. In 10.7 this can be found in the app store, and in other versions just google it and grab it from Apples website. You may need to register as an apple developer. That's a free registration and XCODE is free. It is, however, over 1GB to download, and it takes forever to install. You need it, though.

    1. Install MacPorts using terminal.

    2. Follow the Wine wiki instructions to install wine on mac using macports. DO NOT USE THE PROGRAM Wine Bottler because it does not use standard Wine directories and will either fail or be a major multi-hour long nightmare.

    3. Download the WineTricks script.

    4. Download ToEE from GOG (that's my method, the mac mini doesn't have an optical drive) and Co8 modpack (I am using 6.1)

    5. in terminal, navigate to where you downloaded the Co8 and ToEE setup files.

    6. In terminal, run the command
    "wine ./setupFileNameForToEE"

    7. Follow the directions in the setup program which should look nearly identical to the actual setup in windows. IMPORTANT: it's best to select the option to create your game directory in, for exampe, C:/games/toee without any caps or spaces or periods etc.

    8. Do the same above but for the Co8 modpack setup.

    9. Before running the programs, you should install mono and .Net framework in terminal as follows:
    "winetricks mono28" this could take awhile. Run the setup which should look just like a windows setup.
    "winetricks dotnet20" don't use dotnet10 or dotnet2sp2. Again, follow the normal windows setup routine.

    10. Theoretically, TFE-X-linux should work but I've not been able to do that, so to run the game:

    11. Navigate to your games location, if you followed the above patterns, it should be located here:

    /Home/Users/yourusername/.wine/dosdevices/c:/games/toee

    12. Then run the TFE-X.exe
    "wine TFE-X.exe"

    13. The next part is NOT pretty, but it'll work out fine (I think):
    Running TFE-X.exe for the first time will generate a whole ton of error messages, none of which I understand. Just keep clicking continue on each message. This takes quite a long time. Once it goes to the actual frontend screen, the menu options will probably be blank or have red lines and blank, and neither the vanilla or modpack will show up as options, etc. It's ugly. Just close the window.

    14. Launch the TFE-X.exe again, from step 12. More errors. On the TFE-X frontend, you can click in the location where the modpack is supposed to be listed, and click activate. This is sort of a guessing game. If you clicked in the right place, the activating modpack window will appear with a ton of errors. Again just click continue. Go eat dinner or watch a movie or something. Eventually come back after ~1 hour. If it still says activating, force quite the whole shebang with "apple-option-escape" and force X-11 to close.

    15. Relaunch TFE-X.exe the same way, more errors. If all is good though, the modpack will be active and you'll finally see both the vanilla and modpack listed. Go ahead and set the options, ie. Max HP etc. Then Play the game. Should play perfectly.

    16. Everytime you launch TFE-X.exe hereafter, you'll always receive 1 error, but who cares? It works beautifully.
     
  2. Gaear

    Gaear Bastard Maestro Administrator

    Joined:
    Apr 27, 2004
    Messages:
    11,006
    Likes Received:
    27
    Thanks roolark. :thumbsup:

    Hopefully Agetian will have a fix for these issues for v7.
     
  3. Nilgar

    Nilgar Member

    Joined:
    Oct 23, 2020
    Messages:
    29
    Likes Received:
    0
    Install of Co8 in Mac ToEE Gog version, it is now a lot easier and cleaner. So new simpler method, at bottom of the post the versions used (co8, tfe_x, gog, java, os).

    By searching through internet, this thread was the first pertinent I found, so it seems the proper place for this post.

    I start with a warning not obvious for newbies, when you will play don't forget:
    • To not save by overriding an existing save,
    • nor use auto save,
    • nor use quick save.
    • All of at have a chance to corrupt the save for both games, original version and with co8 version.
    Co8 Installation for ToEE Gog for Mac:
    • No need have ever install wine, most Mac users don't and stick with wineskin, Porting Kit, PlayOnMac, CrossOver, or some other front end manager for wine.
    • Download the modpack you want, and the portrait packs you want in version adapted to modpack version you choose.
    • Launch the Gog ToEE Winskin (in /Applications/GOG/The Temple of Elemental Evil.app/Contents/Resources/game/Temple of the Elemental Evil.app/Wineskin) to:
      • Install the modpack, don't bother if it can't launch the front end at install end.
      • Install the portraits pack you want
    • Go into ToEE packages installed : /Applications/GOG/The Temple of Elemental Evil.app/Contents/Resources/game/Temple of the Elemental Evil.app/Contents/Resources/drive_c/GOG Games/Temple of Elemental Evil
      • Here double click TFE-X.jar.
        • This launch the front end, it inits itself, then you can activate the modpack and each portraits pack, change the setup.
        • => Check the standard co8 front end doc if you wonder what to do.
      • Quit TFE-X by clicking Play button.
    • With Gog ToEE Winskin, select Advanced :
      • For field Windows EXE select: toee.exe in drive_c/GOG Games/Temple of Elemental Evil
      • For field EXE flags enter: -maxlevel:20
    • Then quit Winskin.
    • For a more handy usage create on desktop a Mac link to TFE-X.jar
    That's it. And now to play:
    • Each time right before launching the game to ensure it clears game cache:
      • Double click the TFE-X.jar link, if needed change setup or activate new mods.
      • Click Play button to quit TFE-X.
    • To launch the game you launch it normally through Galaxy or double click on the game (Applications/GOG/The Temple of Elemental Evil.app)
    • And remind to avoid or minimize risk of saves corruption:
      • Don't save by overriding an existing save,
      • nor use auto save,
      • nor use quick save.
      • A simple trick to not forget and make it faster, name saves Empty01, Empty02, and so on.
        • This avoid constantly erase "Empty",
        • it avoids manage loop,
        • and it makes simpler and faster to create new name for next save.
        • For now I didn't quoted problems from number of saves, nor never read anything about that.
    Some details:
    • To install the modpack and portraits pack, in Wineskin use the button Install Software and just select the pack exe you want install, you can let them in Download folder.
    • The launch param of toee.exe seems never change so you can just let -maxlevel:20 in wineskin setup. It's possible that it is pointless, and it could be just a glitch in front end logs.
    • Some resolutions could not work, for your first tries stick to Gog default, once everything seems fine you can try see what works for wine and for you. For example for me 800*600 and 1280*800 work, but not 1680*1050 nor 1280*1024 (no crash but white screen). I didn't bother try them all, I prefer play this game with 800*600 setup. I suppose in some cases it could work by adapting the Gog wine setup.
    • The Front End should detect it's Mac and then launch the game with wine. Logs show it tries and fail. After some investigation, it's probably impossible at least on Mac without wine installed but through some wine front end. The positive is it's fine to launch the game with Galaxy, the negative is each time before launch the game you need launch TFE-X to ensure clear game cache. Do a script to do this and launch the game is possible, I didn't bother with it, after have quit the game I launch the front end, it's fast.
    • In case you wonder about the complementary mod, TemplePlus, it isn't well adapted for being used with wine. I tried a bit but failed make it work, through both install exe or zip package.
    Versions used:
    • Gog ToEE Mac, patch 51630021, installed with Galaxy 2.x.
    • OS High Sierra 10.13.6
    • Co8 version 8.1.0 Standard and 8.1.0 New Content (played more with first), plus modpack adding portraits in version adapted to the co8 version but none for 8.1.0 Standard.
    • TFE-X 4.6 Maywind
    • Java installed inside OS (hadn't to install) version 1.8.0_261 (it's not in os path, search its location on internet).
     
    Last edited: Oct 28, 2020
  4. Sitra Achara

    Sitra Achara Senior Member

    Joined:
    Sep 1, 2003
    Messages:
    2,909
    Likes Received:
    170
    Hi,

    Perhaps you'll find this useful:

    https://rpgcodex.net/forums/threads/temple-on-wine.108280/
     
  5. Nilgar

    Nilgar Member

    Joined:
    Oct 23, 2020
    Messages:
    29
    Likes Received:
    0
    Thank you, I had found this thread already, but, most posts are too old, and those last would require install wine which I never did, front end only install multiple engines for many different versions of wine, so none is really installed in the os.

    From the information given I tried find an engine as close than possible than version quoted, but was far, and failed find any front end allowing me use engine with those versions. And that's only the beginning of the problem, as clearly it's Linux not Mac..

    Still with Cog install, there's a wineskin winery install, I tried apply:
    - dotnet46 with winetricks (maybe also need vcrun2015),
    - so vcrun2015
    - set to Windows 10
    - use virtual desktop,

    With the winskin installed by Gog I couldn't do any but use virtual desktop.

    With another front-end I could have all options but the engine version still very far, installed ToEE by folder copy, then tried install TemplePlus, no go. Then get the TemplePlus zip and installed by copy and try launch it, no go. I'm not specialist enough to dig from such bases, the errors shown wasn't enough helpful to guide me.
     
Our Host!