ToEE Front-End X 4.0 Discussion Thread

Discussion in 'ToEE Front-End X' started by Agetian, Jun 5, 2013.

Remove all ads!
  1. sirchet

    sirchet Force for Goodness Moderator Supporter

    Joined:
    Dec 6, 2003
    Messages:
    3,719
    Likes Received:
    48
    Java's runtime environment is at version 8 now, is the toolkit still using an older version?
     
  2. ConjurerDragon

    ConjurerDragon Established Member Supporter

    Joined:
    Jan 21, 2013
    Messages:
    377
    Likes Received:
    8
    Java 7 is the last version for 32-bit Windows XP systems.
     
  3. sirchet

    sirchet Force for Goodness Moderator Supporter

    Joined:
    Dec 6, 2003
    Messages:
    3,719
    Likes Received:
    48
    Sorry, I took it for granted that you were running a newer OS.
     
  4. Bluepegasus

    Bluepegasus Member

    Joined:
    Jan 25, 2016
    Messages:
    1
    Likes Received:
    0
    Please I need help =(

    I bought the GOG.com version of TOEE for mac. GOG sells it as a wineskin port. I downloaded the CO8 mod installer and installed it, but I need java 7 in order to run TFE-X. I downloaded the offline Java installer for 32 bit from the Sun/Java website. But I am having tremendous problems getting Java to install in the wineskin wrapper's C drive. Every time I try to install Java i get the dreaded Java error 2 with the Java3BilDevices file.

    Specifically the wine log returns the following:

    fixme:heap:HeapSetInformation 0x0 1 0x0 0
    fixme:urlmon:DownloadBSC_OnStopBinding No cache file
    Error opening file C:\users\dorianlopez\Application Data\Sun\Java\jre1.7.0_71\Java3BillDevices.jpg
    Error: 2

    I have tried changing the wine Engine, I have tried installing different builds of Java 7, but no matter what i always get the same wine log and the "oops no new executables" message pops up on the screen when i try to install. i have also deleted TOEE and clean installed the game from GOG--but still the same results. The error 2 situation with Java is infamous and there is info on it on the internet, but unfortunately all the solutions i have seen are applicable only to PC's. i haven't seen anything related to installing Java in a wine wrapper.

    this is the X11 log:
    WineskinX11: main(): argc=10
    Waiting for startup parameters via Mach IPC.
    WineskinX11: do_start_x11_server(): argc=10
    Attempting to use pixel depth of 24
    [4092315.749] WineskinX11 starting:
    [4092315.750] X.Org X Server 1.13.0
    [4092315.750] Build Date: 20120921
    [4092315.750] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
    [4092315.863] Initializing built-in extension Generic Event Extension
    [4092315.863] Initializing built-in extension SHAPE
    [4092315.863] Initializing built-in extension MIT-SHM
    [4092315.863] Initializing built-in extension XInputExtension
    [4092315.863] Initializing built-in extension XTEST
    [4092315.863] Initializing built-in extension BIG-REQUESTS
    [4092315.863] Initializing built-in extension SYNC
    [4092315.863] Initializing built-in extension XKEYBOARD
    [4092315.863] Initializing built-in extension XC-MISC
    [4092315.863] Initializing built-in extension XINERAMA
    [4092315.863] Initializing built-in extension PseudoramiX
    [4092315.863] Initializing built-in extension XFIXES
    [4092315.863] Initializing built-in extension RENDER
    [4092315.863] Initializing built-in extension RANDR
    [4092315.863] Initializing built-in extension DAMAGE
    [4092315.863] Initializing built-in extension MIT-SCREEN-SAVER
    [4092315.863] Initializing built-in extension DOUBLE-BUFFER
    [4092315.863] Initializing built-in extension RECORD
    [4092315.863] Initializing built-in extension X-Resource
    [4092315.863] Initializing built-in extension XVideo
    [4092315.863] Initializing built-in extension XVideo-MotionCompensation
    [4092315.863] Initializing built-in extension GLX
    [4092315.863] x: 0, y: 0, w: 2560, h: 1418
    [4092316.082] (II) GLX: Initialized Core OpenGL GL provider for screen 0
    [4092319.580] x: 0, y: 0, w: 2560, h: 1440
    Engine Used: WS9Wine1.7.14
    Hardware:

    Hardware Overview:

    Model Name: iMac
    Model Identifier: iMac12,2
    Processor Name: Intel Core i5
    Processor Speed: 2.7 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 4 GB
    Boot ROM Version: IM121.0047.B1F
    SMC Version (system): 1.72f2

    Graphics/Displays:

    AMD Radeon HD 6770M:

    Chipset Model: AMD Radeon HD 6770M
    Type: GPU
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 512 MB
    Vendor: ATI (0x1002)
    Device ID: 0x6740
    Revision ID: 0x0000
    ROM Revision: 113-C0170F-170
    EFI Driver Version: 01.00.544
    Displays:
    iMac:
    Display Type: LCD
    Resolution: 2560 x 1440
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Built-In: Yes
     
    Last edited: Feb 10, 2016
  5. Banichi

    Banichi Member

    Joined:
    Dec 29, 2015
    Messages:
    2
    Likes Received:
    0
    You are probably better off not installing Java within the wine environment. You should be able to run TFE-X under native Java (for mac) and TFE-X will detect that it needs to use wine to execute toee.exe.

    nb. this is how it works for me with wine/java/TFE-X on linux. I imagine it should be similar for wine on mac.
     
  6. Rollo Tomassi

    Rollo Tomassi Member

    Joined:
    Nov 18, 2016
    Messages:
    2
    Likes Received:
    0
    I'm having the same difficulty as Bluepegasus. I've wined with and without Java, multiple Java versions, saving to multiple folders. I'm at a loss.
     
  7. Allyx

    Allyx Master Crafter Global Moderator Supporter

    Joined:
    Dec 2, 2004
    Messages:
    4,720
    Likes Received:
    141
    @Rollo Tomassi @Bluepegasus I've never used a linux machine before, but I know a bit about ToEE, and I think I have a dirty solution to help you both.

    Install ToEE as normal, Install Co8 8.1.0 NC (or standard, or KotB) as normal to the ToEE root directory, rename the Co8 8.1.0 NC .tfm file to using the .zip extention, open the .zip file, copy the temple.dll, data and modules folders to your root folder, then launch the game with toee.exe as normal.

    Fingers crossed this should work for you guys. You will lose out on the various front end options, but it should run. You will need separate installations for different modules using this method.
     
    Last edited: Nov 22, 2016
  8. Daryk

    Daryk Veteran Member

    Joined:
    Jan 14, 2012
    Messages:
    1,038
    Likes Received:
    14
    I just received an unexpected request from TFE-X to "modify my computer" (asking for administrator rights). I'm using Win 10, and didn't open TFE-X. I of course denied permission. Has anyone else seen this?
     
  9. Allyx

    Allyx Master Crafter Global Moderator Supporter

    Joined:
    Dec 2, 2004
    Messages:
    4,720
    Likes Received:
    141
    Nope, that is odd. Any ideas @Agetian?
     
  10. Gaear

    Gaear Bastard Maestro Administrator

    Joined:
    Apr 27, 2004
    Messages:
    11,005
    Likes Received:
    27
    Is this a long-existing installation of TFE-X?
     
  11. Daryk

    Daryk Veteran Member

    Joined:
    Jan 14, 2012
    Messages:
    1,038
    Likes Received:
    14
    Yes... I've had it installed for years...
     
  12. Gaear

    Gaear Bastard Maestro Administrator

    Joined:
    Apr 27, 2004
    Messages:
    11,005
    Likes Received:
    27
    Okay well it's doubtful it became corrupted with a virus somehow, as opposed to if it was a new download and had possibly been compromised on the server. I can't remember anymore but doesn't ToEE use Java now? It may just have been asking for permission to control Java settings as applies to running its executable.
     
  13. Daryk

    Daryk Veteran Member

    Joined:
    Jan 14, 2012
    Messages:
    1,038
    Likes Received:
    14
    That makes sense... I did update Java last week, so maybe TFE-X was just a little slow on the uptake.
     
  14. Gaear

    Gaear Bastard Maestro Administrator

    Joined:
    Apr 27, 2004
    Messages:
    11,005
    Likes Received:
    27
    You could try a virus scan on the file anyway, just to be safe.
     
  15. Daryk

    Daryk Veteran Member

    Joined:
    Jan 14, 2012
    Messages:
    1,038
    Likes Received:
    14
    Not a bad idea... thanks again!
     
Our Host!